• 18 Septembre 2018, 19:56:05


Auteur Sujet: Ecran noir lors de la connexion en local  (Lu 1057 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Salif

  • *
  • Tueur
  • Messages: 52
    • Voir le profil
Ecran noir lors de la connexion en local
« le: 24 Décembre 2015, 21:59:10 »
Bonjour à tous !

Je commence dans le LUA, je suis le tuto du wiki j'ai fait que le début, à savoir :
Dans le meta.xml :
Code: Lua
  1. <meta>
  2.      <info author="Votre Nom" type="gamemode" name="Mon serveur" description="Mon premier serveur MTA" />
  3.      <script src="script.lua" />
  4. </meta>


Code: Lua
  1. function joinHandler()
  2.         local x = 1959.55
  3.         local y = -1714.46
  4.         local z = 10
  5.         spawnPlayer(source, x, y, z)
  6.         fadeCamera(source, true)
  7.         setCameraTarget(source, source)
  8.         outputChatBox("Bienvenue sur mon serveur", source)
  9. end
  10. addEventHandler("onPlayerJoin", getRootElement(), joinHandler)

Je tape start myserver dans la console, et quand je me connecte j'ai un écran noir...
Vous savez pourquoi ? Ça fonctionne bien avec le freeroam. Merci.

Hors ligne GtaManiac

  • Vote serviteur bien aimé
  • *
  • Redforce member
  • Messages: 8535
    • Voir le profil
    • GTAOnline.net
Re : Ecran noir lors de la connexion en local
« Réponse #1 le: 25 Décembre 2015, 12:39:12 »
Salut,

Il me semble que tu trouvera tout ce qu'il te faut pour installer, créer et configurer ton propre serveur en suivant les instructions de cette page : http://wiki.multitheftauto.com/wiki/Server_Manual
GTAOnline - TwitchFacebook - Twitter

"Le problème, c'est le choix" - Néo

Hors ligne Salif

  • *
  • Tueur
  • Messages: 52
    • Voir le profil
Re : Ecran noir lors de la connexion en local
« Réponse #2 le: 25 Décembre 2015, 15:24:52 »
Ca ne m'aide pas du tout, normalement j'ai pas cet écran noir.
EDIT : Je crois que je me suis trompé de section je devrais plutôt poster dans la partie Scripting LUA non ?
« Modifié: 25 Décembre 2015, 15:55:48 par Salif »

Hors ligne GtaManiac

  • Vote serviteur bien aimé
  • *
  • Redforce member
  • Messages: 8535
    • Voir le profil
    • GTAOnline.net
Re : Ecran noir lors de la connexion en local
« Réponse #3 le: 26 Décembre 2015, 01:02:52 »
J'ai déplacé dans la bonne section.

Quand tu dis que ça marche bien avec le freeroam, tu veux dire que ce que tu essaie de faire c'est avec ton script fait maison sans gamemode spécifique ?
GTAOnline - TwitchFacebook - Twitter

"Le problème, c'est le choix" - Néo

Hors ligne Salif

  • *
  • Tueur
  • Messages: 52
    • Voir le profil
Re : Ecran noir lors de la connexion en local
« Réponse #4 le: 26 Décembre 2015, 01:18:11 »
Je comprend vraiment pas, ça fonctionne maintenant... J'ai rien changé entre temps.

Hors ligne MK

  • *
  • Gangster
  • Messages: 1834
    • Voir le profil
Re : Ecran noir lors de la connexion en local
« Réponse #5 le: 26 Décembre 2015, 11:32:29 »
Sinon pour ne pas avoir à faire la commande start à chaque fois,
Lances le au lancement du serveur dans le fichier mtaserver.conf, en fin de page
avec <resource src="myserver" startup="1" protected="0" />