• 02 Septembre 2014, 20:48:19


Auteur Sujet: Problème lancement serveur  (Lu 1646 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Lucifer

  • *
  • Tueur en série
  • Messages: 199
    • Voir le profil
    • Midtown States Role Play
Problème lancement serveur
« le: 08 Décembre 2010, 14:56:55 »
Bonjour,

J'ai un soucis, quand je lance mon serveur, sa me met une erreur Windows :
samp-server.exe - Composant introuvable
Cette application n'a pas pu démarrer car LIBMYSQL.dll est introuvable. La réinstallation de cette application peut corriger ce problème.

Pouvez-vous me dire ce que je dois faire...le GM compile correctement sans erreur et warning.



Double post
Quand je lance, sa met plus le message d'erreur Windows mais le serveur démarre toujours pas et dans les logs, sa met cela :

----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3b R2, (C)2005-2010 SA-MP Team

[15:08:52] filterscripts = ""  (string)
[15:08:52]
[15:08:52] Server Plugins
[15:08:52] --------------
[15:08:52]  Loading plugin: sampmysql.dll
[15:08:52]
/*************************************************/
/* SAMP-MySQL v0.15 Plugin loaded successfully ! */
/*************************************************/

[15:08:52]   Loaded.
[15:08:52]  Loading plugin: streamer.dll
[15:08:52]

*** Streamer Plugin v2.3.8 by Incognito loaded ***


[15:08:52]   Loaded.
[15:08:52]  Loading plugin: libmySQL.dll
[15:08:52]   Plugin does not conform to architecture.
[15:08:52]   Failed.
[15:08:52]  Loaded 2 plugins.

[15:08:52]
[15:08:52] Filter Scripts
[15:08:52] ---------------
[15:08:52]   Loaded 0 filter scripts.

[15:08:53]
Connection to MySQL database: Failed !
[15:08:53] Can't connect to MySQL server on '127.0.0.1' (10061)

[15:08:53] Error in mysql_select_db: MySQL server has gone away
[15:08:53] [MYSQL] Perte de la connexion, reconnexion en cours ...
[15:08:54]
Connection to MySQL database: Failed !
[15:08:54] Can't connect to MySQL server on '127.0.0.1' (10061)

[15:08:54] Error in mysql_select_db: MySQL server has gone away
[15:08:54] [MYSQL] Impossible de se reconnecter, arret du serveur
[15:08:54] Loading cars...
[15:08:54] Error in mysql_query: MySQL server has gone away
[15:08:54] Error in mysql_store_result: MySQL server has gone away
« Modifié: 08 Décembre 2010, 15:11:17 par Lucifer »

Hors ligne robyn59

  • *
  • Tueur en série
  • Messages: 109
    • Voir le profil
Re : Problème lancement serveur
« Réponse #1 le: 08 Décembre 2010, 15:36:57 »
il te manque un fichier, robintec@hotmail.fr

ajoute moi je te le passe

Hors ligne Jcvag44800

  • *
  • Grand Banditisme
  • Messages: 617
    • Voir le profil
Re : Problème lancement serveur
« Réponse #2 le: 08 Décembre 2010, 15:42:56 »
Tu peut autent le mettre sur gta online  ???
Tu n'a juste à l'heberger chez un hebergeur et donner le lien.
Comme ça si quelqu'un a la même érreur sa sera bien pour lui au lieu de t'ajouter  :bangin


Hors ligne Lucifer

  • *
  • Tueur en série
  • Messages: 199
    • Voir le profil
    • Midtown States Role Play
Re : Problème lancement serveur
« Réponse #3 le: 08 Décembre 2010, 15:58:26 »
Voilà les logs......

----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3b R2, (C)2005-2010 SA-MP Team

[15:58:03] filterscripts = ""  (string)
[15:58:03]
[15:58:03] Server Plugins
[15:58:03] --------------
[15:58:03]  Loading plugin: sampmysql.dll
[15:58:03]
/*************************************************/
/* SAMP-MySQL v0.15 Plugin loaded successfully ! */
/*************************************************/

[15:58:03]   Loaded.
[15:58:03]  Loading plugin: streamer.dll
[15:58:03]

*** Streamer Plugin v2.3.8 by Incognito loaded ***


[15:58:03]   Loaded.
[15:58:03]  Loaded 2 plugins.

[15:58:03]
[15:58:03] Filter Scripts
[15:58:03] ---------------
[15:58:03]   Loaded 0 filter scripts.

[15:58:04]
Connection to MySQL database: Failed !
[15:58:04] Can't connect to MySQL server on 'localhost' (10061)

[15:58:04] Error in mysql_select_db: MySQL server has gone away
[15:58:04] [MYSQL] Perte de la connexion, reconnexion en cours ...
[15:58:05]
Connection to MySQL database: Failed !
[15:58:05] Can't connect to MySQL server on 'localhost' (10061)

[15:58:05] Error in mysql_select_db: MySQL server has gone away
[15:58:05] [MYSQL] Impossible de se reconnecter, arret du serveur
[15:58:05] Loading cars...
[15:58:05] Error in mysql_query: MySQL server has gone away
[15:58:05] Error in mysql_store_result: MySQL server has gone away

Hors ligne Jcvag44800

  • *
  • Grand Banditisme
  • Messages: 617
    • Voir le profil
Re : Problème lancement serveur
« Réponse #4 le: 08 Décembre 2010, 16:03:26 »
Tu as défini une hote Mysql impossible
Tu as du te tromper l'orsque tu l'as mis


Hors ligne S!m

  • *
  • Messages: 2371
    • Voir le profil
Re : Problème lancement serveur
« Réponse #5 le: 08 Décembre 2010, 16:09:56 »
Salut,

il te manque le fichier libmysql.dll, une petite recherche sur internet et tu trouvera ton bonheur.

ps. si ma mémoire est bonne, il est à placer avec samp-server.exe, sinon dans system32

++Sim++





Hors ligne Lucifer

  • *
  • Tueur en série
  • Messages: 199
    • Voir le profil
    • Midtown States Role Play
Re : Problème lancement serveur
« Réponse #6 le: 08 Décembre 2010, 16:11:01 »
Je l'es déjà ce fichier, sa vient pas de çà..

Peut-on m'aider s'il vous plait...

Karting06

  • Invité
Re : Problème lancement serveur
« Réponse #7 le: 08 Décembre 2010, 16:12:12 »
On essaie mais tu nous écoutes pas.
Jcvag a dit de verifier si tu as bien configurer le accès Mysql ! Fait-le!

Hors ligne S!m

  • *
  • Messages: 2371
    • Voir le profil
Re : Re : Problème lancement serveur
« Réponse #8 le: 08 Décembre 2010, 16:13:56 »
Salut,

Je l'es déjà ce fichier, sa vient pas de çà..

Peut-on m'aider s'il vous plait...

Dans ce cas, il n,est pas au bon endroit, regarde mon post-scriptum, sinon recherche google ou forum, tu n'es pas le premier à avoir ce problème....

++Sim++





Hors ligne steve76

  • *
  • Tueur en série
  • Messages: 159
    • Voir le profil
Re : Problème lancement serveur
« Réponse #9 le: 08 Décembre 2010, 16:40:55 »
Le problèmes est assez claire, c'est marqué noir sur blanc.

Le GM n'arrive pas à se connecter à la Base de données.

Soit tu n'as pas pas de serveur SQL sur ton pc/serveur, soit tu n'as pas mis la base de données dedans ou alors les identifiants dans le GM ne sont pas correct.

++
Steve

Hors ligne Lucifer

  • *
  • Tueur en série
  • Messages: 199
    • Voir le profil
    • Midtown States Role Play
Re : Problème lancement serveur
« Réponse #10 le: 08 Décembre 2010, 17:49:38 »
J'ai mis çà comme identifiant :

#define MYSQL_HOST "localhost"
#define MYSQL_USER "root"
#define MYSQL_PASS ""
#define MYSQL_DB   "samp"

Ensuite quel fichier sont nécessaire s'il vous plait ?

Karting06

  • Invité
Re : Problème lancement serveur
« Réponse #11 le: 08 Décembre 2010, 18:37:59 »
Salut,
Le nom de ta database est samp?
Parce que si il est (par exemple) Lucifer il faut mettre Lucifer au lieu de samp!

Hors ligne Lucifer

  • *
  • Tueur en série
  • Messages: 199
    • Voir le profil
    • Midtown States Role Play
Re : Problème lancement serveur
« Réponse #12 le: 08 Décembre 2010, 18:40:43 »
Mais même pour tester le serveur en local, il faut créer un BD ?

Hors ligne steve76

  • *
  • Tueur en série
  • Messages: 159
    • Voir le profil
Re : Problème lancement serveur
« Réponse #13 le: 08 Décembre 2010, 18:51:30 »
Donc si je comprend bien, tu utilises un GM à base de SQL sans avoir de bdd sur ton pc, ni avoir de connaissance en la matière...

Va faire un tour sur le site du zéro pour comprendre le SQL et après tu verras pourquoi ca ne marche pas.

Karting06

  • Invité
Re : Problème lancement serveur
« Réponse #14 le: 08 Décembre 2010, 18:56:27 »
Oui, tu es obligé. Installe Easyphp et tu as une base de données Mysql